注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

让一切都逝去吧

排骨炖泥菜/猪肝炒苹果/鱼籽狗肉汤/狗头薏米汤

 
 
 

日志

 
 

Unsupported major.minor version 51.0错误  

2013-08-19 23:53:32|  分类: Java |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
      出现这个错误,是编译和运行时java版本不一致造成的。其中版本51这里有说明
http://stackoverflow.com/questions/10382929/unsupported-major-minor-version-51-0
J2SE 8 = 52,
J2SE 7 = 51,
J2SE 6.0 = 50,
J2SE 5.0 = 49,
JDK 1.4 = 48,
JDK 1.3 = 47,
JDK 1.2 = 46,
JDK 1.1 = 45
(source: http://en.wikipedia.org/wiki/Java_class_file )
      我当前的情况是tomcat使用jdk7启动,而项目中使用jdk6编译的,将项目中的jdk版本换成7可以简单地解决这个问题。
  评论这张
 
阅读(5608)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017